Description
The Stackable – Page Builder Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'update_block_style' endpoint in all versions up to, and including, 3.19.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-11-07
Score: 6.4 Medium
EPSS: n/a
KEV: No
AI Analysis

Analysis and contextual insights are available on OpenCVE Cloud.

Remediation

No solution or workaround provided in the CVE record.

Additional remediation guidance may be available on OpenCVE Cloud.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

References
Link Providers
https://github.com/gambitph/Stackable/pull/3725 cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.6/src/deprecated/block-defaults/custom-block-styles.php#L155 cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.6/src/deprecated/block-defaults/custom-block-styles.php#L181 cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.6/src/deprecated/block-defaults/custom-block-styles.php#L223 cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.6/src/deprecated/block-defaults/custom-block-styles.php#L432 cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.8/src/deprecated/block-defaults/custom-block-styles.php#L155 cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.8/src/deprecated/block-defaults/custom-block-styles.php#L181 cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.8/src/deprecated/block-defaults/custom-block-styles.php#L223 cve-icon
https://plugins.trac.wordpress.org/browser/stackable-ultimate-gutenberg-blocks/tags/3.19.8/src/deprecated/block-defaults/custom-block-styles.php#L432 cve-icon
https://plugins.trac.wordpress.org/changeset/3609541/stackable-ultimate-gutenberg-blocks/trunk/src/deprecated/block-defaults/custom-block-styles.php cve-icon
https://www.wordfence.com/threat-intel/vulnerabilities/id/1d4da874-23c8-4df4-b776-6046ce8d705a?source=cve cve-icon
History

Sat, 07 Nov 2026 04:45:00 +0000

Type Values Removed Values Added
Description The Stackable – Page Builder Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'update_block_style' endpoint in all versions up to, and including, 3.19.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title Stackable <= 3.19.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'save' Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-07T04:27:12.469Z

Reserved: 2026-05-26T15:34:01.308Z

Link: CVE-2026-9601

cve-icon Vulnrichment

No data.

cve-icon NVD

No data.

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

No data.

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')